App Store inaccessibile dall'iPhone con iOS 3.x

Chiedo scusa se è la sezione sbagliata per aprire questo topic.
Sarei estremamente grato alla Redazione di iPhoneItalia, se volesse approfondire il tema di cui in oggetto: qualche giorno fa, l’App Store è rimasto momentaneamente inaccessibile, anche da pc/mac con iTunes, per via di qualche aggiornamento in corso da parte di Apple; in pratica era impossibile loggarsi.
Il problema è stato risolto ed iPhoneItalia lo ha prontamente segnalato (Problemi nell’accesso ad iTunes Store, iTunes Connect e iCloud: password non riconosciuta [AGGIORNATO: problema in fase di soluzione] - iPhone Italia – Il blog italiano sull’Apple iPhone 4S, iPhone 4 e 3GS), ma da allora l’App Store è praticamente chiuso (dal melafonino) a chi, come me, monta un sistema precedente il 4.x (appare uno sfondo grigio al posto delle immagini di anteprima delle applicazioni e i tasti d’acquisto, condivisione e lettura delle recensioni non funzionano: è quindi impossibile scaricare/aggiornare applicazioni).
Lo so, ho ancora il 3.1.3 di fabbrica e dovrei aggiornare, ma non l’ho mai fatto, sia perchè non sapevo di dover salvare i certificati per un eventuale downgrade (forse adesso li potrei salvare con iFaith?!?), sia per l’incompatibilità con iOS 5.x di alcune applicazioni a me care.
Vi segnalo anche questa discussione, fra le tante, aperta sul forum dell’Apple Support, con tanto di screenshots su quello che succede:
https://discussions.apple.com/message/17018143#17018143
Se non fosse un disservizio, ma una scelta di Apple per forzare gli utenti all’upgrade, mi parrebbe un tantino una violazione della licenza d’uso e/o del Codice del consumo…
Grazie a tutti per l’attenzione!

Forse è il caso di aggiornare.
Se non vuoi aggiornare a ios 5, sul 3GS (e solo sul 3GS) puoi montare il 4.1 essendo ancora firmato non necessita di aver salvato gli shsh.
PS: cosa non ti funzionerebbe con ios 5?

Ecco qui,non e’ solo un tuo problema

http://www.iphoneitalia.com/iphone-e-ipod-touch-con-ios-3-1-3-non-possono-scaricare-nuove-app-direttamente-dallapp-store-319754.html

Puoi solo aggiornare ad iOS 5.0.1

Ecco che il problema e’ stato risolto

http://www.iphoneitalia.com/apple-corregge-il-problema-di-ios-3-1-x-e-dellimpossibilita-di-scaricare-app-dalliphone-320039.html

Ho notato, ma ti ringrazio della segnalazione!

Prego :smiley: