Problema con limite packages scaricabili da Cydia

Ciao a tutti.
Ho un problema con un errore di Cydia che non mi permette di scaricare più i contenuti delle repositories.

L’errore che mi appare è questo:

IMG_2834.jpg

E praticamente non mi caricava più nulla in Cydia: risultava tutto vuoto.

Così ho seguito questo consiglio:
Cydia non carica i contenuti? Ecco come risolvere in pochissimi secondi - iPhone Italia Blog
Ed è riapparso tutto (ma soltanto quello che riguardava i pacchetti già installati + le repositories).

Dopodichè vado per fare un “Aggiorna” nella sezione “Novità” e la cache si riempie di nuovo con tutti i pacchetti installabili delle repositories, e il problema ritorna…
Esce di nuovo la schermata che dice:

Wow, you exceeded the number of package names this APT is capable of.
Problem with MergeList /var/lib/dpkg/status
The package lists or status file could not be parsed or opened.

Bene… Vado a cercare qualcosa e trovo questo:
Please help to increase APT cache limit

che praticamente dice di aumentare il limite dei packages scaricabili tramite MobileTerminal.
L’unico problema è che ho provato a seguire il tutto alla lettera ma trovo ci siano delle cose che non vanno
sia nelle mie cartelle, sia nel nel post del forum di Modmyi.

Innanzi tutto sul forum di Modmyi, Mcmuzzy scrive questo:

Wow, you exceeded the number of package names this APT is capable of.
Problem with MergeList /var/lib/dpkg/list/status
The package lists or status file could not be parsed or opened.

Ed il mio errore invece non contiene list nel percorso, e tale cartella non ce l’ho neanche.
Ho dovuto postarvi questo errore perchè era quello più simile al mio per quanto riguarda iPhone,
le altre cose che ho trovato su Google scrivendo il mio errore, riguardano soltanto
Linux, Debian e Ubuntu e detto tra noi: io non ci capisco molto…

Le istruzioni per agire con MobileTerminal, comunque le ho seguite lo stesso:

Terminal instructions

solution to fix it is just increase the value APT::Cache-Limit at the /etc/apt/apt.conf.d/70debconf.

sudo gedit /etc/apt/apt.conf.d/70debconf.
Then put this code
APT::Cache-Limit “100000000”;
at the below on that file and then save it.
Next typing this code on your terminal
sudo apt-get clean && sudo apt-get update --fix-missing
and you won’t find apt cache limit again in the next time.

ma il terminale non riconosce neanche la prima parte di quello che scrivo…

Ho pure notato che, di questo percorso /etc/apt/apt.conf.d/70debconf. l’ultimo file mi manca…
Così ho provato a crearlo nel formato giusto, l’ho messo nella cartella apt.conf.d e ho riprovato il procedimento.

Ma purtroppo niente da fare, anche sta volta il terminale non mi riconosce il primo comando.

Il problema sembrerebbe complesso, ma in realtà basterebbe aumentare questo benedetto limite.
Mi servirebbe qualcuno che ha già avuto questa esperienza e l’ha risolta.

Per favore contattatemi se sapete cosa posso fare…

Purtroppo non mi è mai capitato e non so aiutarti. Peró sono curioso di sapere quanti pacchetti hai installato, perchè io ne ho 103 e pensavo di averne parecchi ma evidentemente tu mi batti…qual è il limite?

Inviato con TapaTalk su IPhone 4S