Downgrade e nessun servizio iphone 3GS-16GB

Salve a tutti.Innanzitutto complimenti per questo forum da cui ho attinto numerosi spunti per arrivare al punto in cui sono…ma brevemente vi riassumo ciò che ho fatto.
Mi è stato dato un iphone 3GS di cui non conosco la storia pregressa ma solo che era stato aggiornato a ios 5 e che all’accensione mi richiedeva sempre di fare l’attivazione.Compilavo i campi lingua,nazione,localizzazione ma poi, sia che mi connettevo in wifi (impossibile contattare il server) sia che lo facessi tramite iTunes (che mi diceva che non era stata installata alcuna scheda sim), non riuscivo mai ad usare questo iphone.
Da tinyumbrella 5.01.00 ho rilevato che l’iphone ha una baseband 06.15.00-6.4_M3S2 (da cui presumo quindi che sia già un cellulare sbloccato per usare altre sim) e che per questo cellulare ho i certificati per ios 4.0/4.0.1/4.1/4.2.1.
Decido quindi di fare un downgrade alla versione 4.2.1 perchè è untethered e io la preferisco. Mi scarico il firmware per il mio 3GS (iPhone2,1_4.2.1_8C148a_Restore.ipsw), lo carico in Snowbreeze 2.2.1, scelgo la modalità Expert, lascio attivate le sole due opzioni ''Activate the iPhone" e “Install Animated Boot Logos”, mi creo il custom firmware, che Sn0wBreeze chiama “sn0wbreeze_iPhone 3GS-4.2.1a.ipsw”, da passare in dfu ad iTunes (mentre in background ho tinyumbrella con il server avviato) e faccio partire la scrittura del firmware custom sull’iphone.Tutto va a buon fine,accendo il cellulare che finalmente con questa procedura si attiva,vado in connessione wifi per accedere a Cydia e installo l’ultima versione di Ultrasn0w che è la 1.2.4 per sbloccare le sim ma anche dopo il riavvio continuo ad avere che le mie sim (vodafone e coop) non vengono viste e mi compare sempre “Nessun servizio” in alto a sinistra.
Chiedo quindi a tutti se c’è qualcuno che gentilmente sa indicarmi dov’è che sbaglio…
Grazie

La baseband sara’ corrotta,non potrai fare nulla

Billie ti ringrazio per la pronta e sollecita risposta. Mi sai almeno dire se IO dal lato mio, per quanto riesci ad evincere dal mio post, ho sbagliato qualcosa,se avevo altre strade da intraprendere e che posso ancora provare e, in ultima istanza, se si può in qualche modo sovrascrivere la baseband? Inoltre volevo sapere, in caso di esito negativo di riscrittura o ripristino in qualche modo della baseband, se si potrebbe risolvere qualcosa aspettando il jailbreak untethered di ios 5 (iPhone2,1_5.0_9A334_Restore) ?

No,tu hai eseguito tutto correttamente (da manuale)
A quel punto la baseband si sarebbe dovuta sbloccare con tutte le SIM.
Il jailbreak untethered non risolverà nulla,puoi attendere un downgrade di questa baseband che dovrebbe uscire a breve.

Ti ringrazio Billie…gentilissimo!! Attenderò allora. Buona serata e ancora grazie.

Ciao Billie, riscrivo di nuovo perchè rileggendo la tua risposta di prima mi sono soffermato sulle guide che hai in firma e ho letto quella per sbloccare la parte telefonica dei 3G/3GS con ios 4.1/4.2.1 … proprio quello che sarebbe servito a me insomma e ho provato ad eseguirla nonostante si parli di un jailbreak tethered. Fatto sta che ho seguito alla lettera la sopracitata GUIDA, ho dato a redsnow il firmware originale per il mio 3GS ‘iPhone2,1_4.2.1_8C148a_Restore.ipsw’, lo ha riconosciuto come firmware accettabile, ho risposto ‘‘si’’ al fatto che avevo un 3GS con nuovo boot,flaggato ‘‘install cydia’’ e ‘‘install ipad baseband’’ e fatto partire la scrittura (a tal proposito sottolineo che in windows7 redsnow deve essere fatto partire in compatibilità XP e come amministratore sennò si blocca in “uploading ramdisk”…io avevo appunto dimenticato di settare la compatibilità :rolleyes:).Comunque, fatto ciò il cell si riavvia e finalmente mi riconosce la scheda sim ora!!:thumbsup: Deve in qualche modo aver sovrascritto la baseband corrotta di cui parlavamo prima…
Ora però mi sorge una domanda da porre.Poichè nella guida si dice che il jailbreak è tethered, io mi aspettavo quindi che il riavvio del cell andasse fatto sempre via-redsnow. Come posso verificare questa cosa col mio cell e cioè capire se il mio jailbreak è tethered o untethered? Ho provato a spegnere il cell e a riaccenderlo e lo ha fatto senza alcun problema,senza bisogno di essere collegato al pc. Forse ha tenuto memoria del predente jailbreak fatto con snowbreeze? A te la parola e a chiunque saprà rispondermi.Grazie.

Mi rispondo da solo…credo che per riavvio non si intenda un semplice spegnere e riaccendere il cellulare ma entrare ed uscire dal dfu…cosa che a me non andava confermandomi appunto che è un jailbreak tethered. Non mi resta che reinstallare un custom firmware creato con snowbreeze come fatto all’inizio del post visto che ora la baseband sembra funzionare.

Esatto,prova ad inserire iOS 4.1

Ciao Billie, ho continuato sulla versione 4.2.1 anche perchè con quella stavo lavorando…Alla fine sono arrivato alla soluzione del mio problema che qui vengo a riassumere dall’inizio anche a beneficio di chi vi si potesse imbattere.

  1. Il mio problema era di avere questo cellulare 3GS che tramite tinyumbrella ho visto avere ios 5 e baseband 6.15.00 ma che era inattivabile sia da rete wifi che da itunes.Ne ho salvato i certificati e la versione più recente del firmware risultava essere la 4.2.1 per me.Ho fatto quindi un downgrade dall’ios 5 (inattivabile) alla versione 4.2.1 nel modo in cui ho indicato nel mio primo post tramite Sn0wBreeze.Il problema si risolve in parte perchè a questo punto mi ritrovo con un cellulare comunque attivato,e quindi esplorabile nei suoi menù,ma che mi segnala sempre ‘‘Nessun servizio’’ perchè non vede la sim nonostante avessi installato UltraSn0w da Cydia.
  2. Alla ipotesi di Billie che ci potrebbe essere un problema di baseband corrotto comincio a pensare se c’è qualche modo di sovrascriverla e anche se Billie è purtroppo categorico sul fatto che non ci si potrà fare nulla, io comunque decido di provarci dato che non ho nulla da perdere…tanto più che l’occhio mi cade su questa GUIDA che lui ha in firma.Decido quindi di fare un jailbreak, seppur tethered, del mio iphone 3GS secondo le modalità che ho descritto nel post #6 di questo thread.Il jailbreak va a buon fine e a questo punto ho un cellulare che, attraverso l’installazione di UltraSn0w, riconosce la mia sim anche se in modo tethered.
  3. Il passo successivo è stato quello di riavviare di nuovo RedSn0w 0.9.6b5,dargli in pasto il firmware “iPhone2,1_4.2.1_8C148a_Restore.ipsw”, cliccare ‘‘Si’’ perchè ho un 3GS new boot e di mettere il cellulare in dfu tramite “Just enter pwned DFU mode right now”.A questo punto ho un cellulare in DFU tramite RedSnow.
  4. Avvio tinyumbrella e il suo server a scopo preventivo per evitare errori di iTunes.
  5. Avvio iTunes che giustamente vede un iphone in modalità DFU. Clicco su shift+Ripristina e come firmware da ripristinare gli do il firmware ‘‘sn0wbreeze_iPhone 3GS-4.2.1a.ipsw’’ che avevo creato all’inizio con Sn0wBreeze e che scelgo perchè è untethered.
  6. Il primo segno confortante al riavvio è che ora vedo le tacchette di segnale, senza comunque il nome dell’operatore di telefonia, invece della dicitura ''Nessun servizio" in alto a sinistra. Procedo quindi con l’installazione di UltraSn0w attraverso Cydia.Tutto va bene, il cell si riavvia e finalmente ho il cellulare attivato e con jailbreak untethered. Come ultima prova metto in DFU il cell e ne riesco per verificare effettivamente la bontà dell’untethered ed è superata anche questa.
    Un grazie a Billie,a tutti gli utenti inconsapevoli che tramite la lettura dei loro interventi in giro per il forum hanno contribuito comunque a farmi capire certe cose, e al Forum tutto!! Mi scuso per il post chilometrico :wink: ma spero che possa servire anche ad altri.Buonasera

Prego :slight_smile:

Buongiorno ragazzi mi unisco a questa discussione , visto che ho un problema ad un iphone 3gs tedesco t-mobile ,che cercavo di sbloccare seguendo le vostre procedure per il downgrade a ios 4.1 con custom firmware creato da snowbreeze. Inizialmente il tel montava il firmware 4.3.5 ed e’ stato erroneamente aggiornato dalla persona che me lo ha dato ad ios 5.0.1 . Ieri ho creato il custom con snowbreeze e ho ripristinato l’iphone ad ios 4.1 , tutto bene tranne che per il riconoscimento della sim . Premetto che il tel ha la baseband 05.16.05 e quindi volevo aggiornarla a quella specifica per l’ipad effettuando l’operazione con redsnow che pero’ riconosce solo il fimrware 4.2.1 . Ho creato un custom 4.2.1 e ho provato a installarla nel tel con redsnow spuntando solo l’opzione dell’installazione della baseband dell’ipad . In pratica l’operazione si e’ fermata su uploading ramdisk e quindi leggendo il post precedente di frank , mi rendo conto che avrei dovuto far partire redsnow in modalita’ xp. Ad ogni modo blocco la procedura e da li ritento con itunes a reinstallare il firmware 4.1 . Bene da qui ho cominciato ad avere una serie di errori vari ( 1600 . 3194 ). Sono riuscito a riporistinare a ios 5.0.1 ma come ben sapete non posso portare la procedura a termine causa sim non compatibile. Il problema e’ che non riesco piu a fare downgrade con la solita procedura e il firmware precedentemente creato con snowbreeze. Posso sperare di risolvere in qualche modo?

Ciao simino…il tuo errore 1600 mi capitava perchè visto che oramai sul cell c’è un custom firmware,non puoi mandarlo in dfu semplicemente,come sei abituato a farlo…ma devi mandarlo in dfu tramite redsnow spuntando l’ultima casella “Just enter pwned DFU mode right now” e iTunes lo vedrà in modalità ripristino e dovrebbe correttamente scrivere il custom firmware che vuoi tu. Da quello che ho capito gironzolando è che ora che abbiamo la BB 6.15.00 non potremo installare più firmware originali della Apple ma solo custom firmware. L’errore 3194 mi accedeva perchè c’era tinyumbrella che non faceva partire il server tss per un motivo…e il motivo era che il mio firewall lo bloccava dato che tinyumbrella agiva sulla porta 80. Ho disattivato il firewall momentaneamente per permettere a tinyumbrella di operare correttamente e il problema non si è più presentato. Una domanda…quando avvii tinyumbrella con l’iphone connesso,leggi i certificati e le versioni di firmware per cui li hai?

Ciao Frank , adesso c’e’ il firmware 5.0.1 e tinyumbrella mi riconosce modello , baseband , ecid , seriale ed imei ,ma non versione firmware. Io uso solo firewall di windows che ho appena disattivato. Il problema adesso e che non riesco a fare downgrade a ios 4.1 . Adesso ho attivato tss server con tiny , provo a vedere se riesco a farlo , ti faccio sapere.

Ok

Scaricati iReb rc4 dal blog
http://www.iphoneitalia.com/ih8sn0w-rilascia-ireb-rc4-214756.html poi segui questa guida per crearti il custom firmware di iOS 4.1:
http://www.iphoneitalia.com/guida-eseguire-il-jailbreak-del-firmware-4-1-con-sn0wbreeze-2-1-windows-168536.html

Qui trovi invece iOS 4.1 per iPhone 3GS,necessario per sn0wbreeze:
http://appldnld.apple.com/iPhone4/061-7938.20100908.F3rCk/iPhone2,1_4.1_8B117_Restore.ipsw

Usa la modalità “Expert Mode” per crearti il custom firmware e metti la spunta su “Activate the iPhone”

Dopo aver creato il custom del firmware apri iReb e metti in dfu l’iPhone (seguendo ciò che ti dirà lo stesso tool) poi ripristina il firmware creato con sn0wbreeze con iTunes tenendo premuto su SHIFT e premendo su RIPRISTINA

niente da fare errore 2005 adesso, eppure ci deve essere un modo per fare il downgrade

Billy ma io tutto questo l’ho gia fatto propio seguendo la tua guida, dici di rifare la procedura e ricreare un’altro custom firmware?

Ragazzi sono riuscito a fare downgrade al 4.1 . Adesso mi servirebbe il vostro aiuto per tentare di sbloccare la parte telefonica. Che faccio installo ultrasnow da cydia? Oppure provo la procedura con redsnow per la baseband e dopo installo ultrasnow?

La baseband che hai a questo punto qual è?

Se hai già la 06.15.00 come bb usa direttamente ultrasn0w