4s: disabilito il 3g ma al reboot si attiva da solo

è normale oppure è un difetto?
Aggiornamento situazione: mi sono fatto sostituire la SIM vi aggiorno nell’arco della giornata.

P.s. Chiedo scusa se ho sbagliato sezione, grazie per lo spostamento. :wink:

Stai postando nella sezione errata,sposto nella sezione iPhone 4S
La prossima volta stai più attento.

L’ho notato anch’io, anzi me l’ha fatto notare un collega con il 4S.
Se ci ricordiamo bene, fra l’altro, la 5.1, versione con la quale uscì il 4S (se non sbaglio non c’e’ supporto ufficiale della 4.3.5 al 4S) non permetteva neanche lo switch 2G \ 3G !

Facendo qualche prova con il 4S, ho notato che a differenza del 4, quando abiliti \ disabiliti il 3G il 99% delle volte fra l’altro “calano” le tacche di brutto e scompare persino il nome del gestore, come se il cell si fosse scollegato e ri-collegato alla rete. La mia personale teoria e’ che la doppia antenna, ecc… ecc… del 4S sia attiva solo il 3G, e quindi disabilitandolo la baseband in un qualche modo si “ri-inizializzi” e, a causa di un bughetto, perda questo settaggio al boot (magari non sta in un’area di lavoro del modem che viene scritta su memoria ma rimane in ram volatile).

Succede anche a me…provato con 2 4S… sarà proprio un bug

Ho anche notato che al boot impiega un pochino a prendere la linea. Secondo me fra poco uscirà un aggiornamento software , leggo anche da altre parti che hanno lo stesso problema.

Sent from my iPhone using Tapatalk

Non è un bug ma una cosa logica. Perché mai si dovrebbe avviare avendo prestazioni inferiori?

Nel senso che potrebbe avere dei difetti?

Sent from my iPhone using Tapatalk

Scusa non sono stato chiaro :slight_smile: Intendevo che non avrebbe senso che si avviasse l’iPhone in modalità 2g Si perderebbero il 90% delle potenzialità del telefono

Aggiornamento: ma quindi è una cosa normale o mi devo dar cambiare il telefono? Ho cambiato SIM ed è sempre la stessa cosa

Sent from my iPhone using Tapatalk

Sul 4S diciamo che è normale… non è un problema del tuo telefono.

Perchè allora sugli iphone precedenti al 4S, cio’ non avviene???
Io dico che dipende dal fatto che il 4S nativamente non supportava la disattivazione del 3G (reintrodotta con il 5.1)

E’ una cosa “normale” dato che lo fanno tutti gli iPhone 4S, non e’ il tuo ad essere buggato.
Rimane da vedere se:

a) E’ un qualcosa a livello “fisico” del modem (potrebbe anche essere) in quanto il settaggio che gli dice “vai in 2G” magari non puo’ essere salvato.
b) E’ un bug della baseband, e Apple se vuole potrebbe risolverlo.

A rigor di logica io mi aspetto che quando lo accendo lo ritrova configurato come l’ho lasciato, ma se i problemi fossero solo questi… secondo me e’ un FINTISSIMO problema…

Il fatto, come detto, che il primo iOS per l’iPhone 4S manco avesse lo switch 3G\2G, la dice lunga: secondo me non e’ un bug ma l’accoppiata hardware \ baseband forse non permette di salvarsi questo settaggio.

Perché Apple se c’e’ una cosa che ha rifatto da zero o quasi nel 4S non e’ tanto la CPU dual core ma tutto il sistema di antenna radio, WIFI e Bluetooth…
E rifacendo completamente l’hardware anche il software ci deve stare dietro, e di brutto…

Infatti sono d’accordo con te sulle conclusioni.

Fatto sta che scoccia stare li ogni volta a staccare il 3G appena si accende…
Accade anche dopo i respring.
E accade anche con SbSettings, quindi non solo con l’impostazione nativa dell’iPhone.

Ah quindi accade anche dopo un respring? Interessante… teoricamente il respring uccide solo alcuni processi (principalmente la springboard appunto). Non mi sembra ad esempio, che dopo un respring tu perda gli IP wifi e 3G, confermi che non ricordo bene? Insomma sto cercando di capire se il respring re-inizializza la baseband :wink:

Rettifico: Il respring NON resetta l’impostazione… Ricordavo male…sorry :slight_smile:

Aggiornamento: sono stato dove l’ho comprato E ci stavano altre tre persone che lamentavano lo stesso problema. Il venditore ci ha detto che se volessimo lo possiamo cambiare ma il problema non si risolve

Sent from my iPhone using Tapatalk

secondo me e’ un finto problema, ripeto… non so dove sia la seccatura…
mi abilitasse i dati autonomamente, ecco, ma cosi’… tutto IMHO!

Bè da me che la copertura UMTS è scarsa, soprattutto a casa mia (0 tacche) è una bella seccatura…

Yes ma 3G non vuol dire SOLO 3G, è il Cell che decide in base al alcuni parametri del gestore stesso chi ascoltare…